flutter error: GoogleSignInPlugin.java uses or overrides a deprecated API

i am developing my flutter app, but at the momet to run project this messaje shows in the terminal: Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\google_sign_in-5.2.3\android\src\main\java\io\flutter\plugins\googlesignin\GoogleSignInPlugin. java uses or overrides a deprecated API. Note: Recompile with -Xlint:deprecation for details.


It is just a warning that the plugin uses deprecated API. You will not have any problem using deprecated code. In the future release of the package it will be fixed, and you can then upgrade your package.